1
0
Fork 0
mirror of https://git.sr.ht/~roxwize/.dotfiles synced 2025-01-31 07:03:36 +00:00
.dotfiles/nixos/hosts/ioides/configuration.nix
roxwize c38f040574
~
Signed-off-by: roxwize <rae@roxwize.xyz>
2025-01-24 16:08:11 -05:00

57 lines
1.3 KiB
Nix

{ config, lib, pkgs, ... }:
{
imports = [
./hardware-configuration.nix
../base.nix
];
boot.loader = {
efi = {
canTouchEfiVariables = false;
efiSysMountPoint = "/efi";
};
grub = {
enable = true;
efiSupport = true;
efiInstallAsRemovable = true;
devices = [ "nodev" ];
};
};
# Music pendrive
fileSystems."/mnt/world" = {
device = "/dev/disk/by-uuid/639bae80-0f5d-481c-ae4e-d2c70f754a1c";
fsType = "ext4";
neededForBoot = false;
};
networking.hostName = "ioides";
services = {
xserver.videoDrivers = [ "nvidia" ];
};
hardware = {
graphics = {
enable = true;
extraPackages = with pkgs; [
intel-media-sdk
];
};
nvidia = {
modesetting.enable = true;
powerManagement = {
enable = false;
finegrained = false;
};
open = false;
nvidiaSettings = true;
package = config.boot.kernelPackages.nvidiaPackages.stable;
};
};
fonts.fontconfig.subpixel.rgba = "rgb";
time.timeZone = "America/New_York";
system.stateVersion = "24.11";
}