nest-home/redis/Redis.nix
2024-08-16 10:59:52 +02:00

34 lines
No EOL
548 B
Nix

{ pkgs, ... }:
{
home.file = {
".config/redis/redis.conf" = {
source = ./redis.conf;
};
};
systemd.user.services = {
Redis = {
Unit = {
Description = "Vic's redis";
After = [ "network-online.target" ];
};
Service = {
Type = "simple";
ExecStart = "redis-server .config/redis/redis.conf";
SyslogIdentifier = "hackey";
Restart = "always";
TimeoutSec = 0;
};
Install = {
WantedBy = [ "default.target" ];
};
};
};
}